[LXDE]WinAte - Windows 7/8 Theme pack
GTK2 Themes
Score 61%
Description:

With this brand-new WinAte - Windows 7/8 Transformation Pack for LXDE - you will be able to get all the icons and overall appearance of Windows to your GNU/Linux box, without spending lots of resources nor having to adapt old Gnome 2 themes. Everything works just by executing the install.sh script. Just do that, logout and login again, and there should be a different feeling in the whole system.

I took some stuff from the old Win2-7 pack, and a bit of inspiration from the Imagine 7 and Imagine 8 themes for Openbox. All the config files, and the modifications to both sources were made entirely by me. Find me in Taringa.net

Required packages: gtk2-engines-murrine; gtk2-engines-pixbuf; compton.

IMPORTANT: THIS PACK HAS BEEN DESIGNED TO WORK WITH DEBIAN 8 (JESSIE), AND PROBABLY WON\'T WORK WITH ANY PREVIOUS VERSION. UBUNTU IS CURRENTLY SUPPORTED (BY INSTALLING LXDE PACKAGE AND COMPTON PPA), BUT LUBUNTU ISN\'T (THERE WILL BE AN UPDATE AVAILABLE SOON TO GET IT WORKING PROPERLY

For updating the pack, please uninstall any previous version first.
_____________________________________________

Con este completo pack de transformación de Windows 7 para LXDE, podrás modificar la experiencia de usuario y facilitar tu llegada al mundo de GNU/Linux! Sólo ejecuta el script \"install.sh\" en una terminal, cierra sesión y, al volver, todo estará renovado. 100% Libre.

Tomé algunas cosas del antiguo Win2-7 pack, y me inspiré un poco en los temas para Openbox Imagine 7 e Imagine 8 (pero no me gustaron del todo, por eso hice los míos propios). Todos los archivos de configuración y modificaciones a las fuentes las hice enteramente yo. Búscame en Taringa.net :)

Paquetes necesarios: gtk2-engines-murrine; gtk2-engines-pixbuf; compton.

IMPORTANTE: ESTE PACK ESTÁ DISEÑADO PARA FUNCIONAR CON DEBIAN 8 (JESSIE), Y PROBABLEMENTE NO FUNCIONE CON NADA ANTERIOR. UBUNTU ACTUALMENTE ESTÁ SOPORTADO (INSTALANDO PREVIAMENTE EL PAQUETE LXDE), PERO LUBUNTU NO (HABRÁ UNA ACTUALIZACIÓN PRONTO QUE LO SOPORTARÁ)

Para actualizar el pack, por favor desinstala cualquier versión previa antes de hacerlo.

Requirements / Requisitos:

- LXPanel
- LXSession (>= 0.4.9)(icons, gtk theme and cursor)
- PCManFM (wallpaper)
- Compton
- Openbox
- SLiM (for login theme)

DogeCoins donations accepted!
Such wallet: DCe1FfwLR33n1Smio2RJZdyTHk3TP8ZRFd
Last changelog:

3 years ago

0.1 First version, lots of errors
0.2 Almost everything work, apparently something happened with the cursor
0.2.1 Found the mistaken location for the cursor
0.2.2 A few improvements in compatibility
0.3 Lots of improvements! I have re-written the install script, and now it fails so much less than before
0.3.1 Removed msstyles, due to Copyright issues
0.4 Completely rewritten themes. Now it looks a lot much like Win8
0.4.1 Official Win8 wallpapers added
0.5 Merged version 0.3.1 into W8 script, added new features and uninstall script now it\'s been auto made each time you install
0.5.1 Fixed wallpaper recover when using uninstaller
0.5.2 Fixed ob-theme issues (if nothing happens, this could be the first RC)
0.6 RC-1 Whole new installer, now much smarter than ever! Auto-detects non-compatible distros, and writes a perfect uninstaller (everything is restored with a single click). Added GTK3 support, Win8 cursor and GTK2 theme.
1.0 Minor details improved. Added experimental support for SLiM
1.1 Added complete support for SLiM.
1.2 Added ability to customize SLiM background.
1.2.3 Now using sudo to gain root access
1.2.4 Login background minor bug fixed.
1.3 Minor bugs fixed. Added support for Arch Linux. Now you can turn off aero-like effects.
1.3.5 Minor bug that were making it impossible to install it without compton fixed. Translation to french added. Thanks to Franí§ois Foyer :D

gandrespg

5 months ago

no puedo descargarlo, ayuda por favor. gracias

Report

mikeuz

2 years ago

hey, baje un zip de github... le doy en install y nada...en ocasiones me abre solo una ventana de terminal...alguna sugerencia?

Report

C

nhermosilla14

2 years ago

Efectivamente se ejecuta, pero por consola. Abre una terminal y desde ahí cambia a la carpeta del script. Una vez allí corres:
$ ./install.sh
o
$ bash install.sh

Así verás los pasos uno a uno (sabrás que lo hiciste bien porque te preguntará varias cosas, partiendo por el idioma).

Saludos!

Report

guberman1

3 years ago

Ignore the comment above me...^^
I ran the install.sh file and answered all of the questions, then I tried to log off like it says, and when I log back on nothing changes. Why?

Report

C

nhermosilla14

3 years ago

I need more info to be of any help, because there could be a lot of different issues related to your os version. Please reply with your OS and version of it, and as many other data related (lxsession version, any tweak that you had applied, etcetera) as possible.

Report

guberman1

3 years ago

What am i supposed to do after downloading it?

Report

spamme2

3 years ago

@nhermosilla14

Can You Post a small HowTo or can you config the install-Script for check the Distribution and (apt-get) install the packet that need WinAte.

I have testet on a blank ubuntu 14.04 and 12 install from a boot-cd. i couldn't run the theme ;-(

best regards
dom

Report

C

nhermosilla14

3 years ago

Mmm...I think that everything should work if you install gtk2-engines-murrine, lxde, compton(you need to add the proper ppa, google that) and slim. Do a "sudo apt-get lxde gtk2-engines-murrine slim compton" and it should be enough. I don't use Ubuntu in my pc since...I don't know, 2011? I tested it a few times, but the truth is I did this theme for Debian, so the only thing that I can actually assure you is that if you install the package "lubuntu-desktop", nothing will work at all. Good luck!

Report

Ambiance-69

3 years ago

This is the best theme I have ever saw! Good job!

Report

C

nhermosilla14

3 years ago

Thank you! I've checked your Windows-ish themes too, and the XP Royale one is definely awesome (I was about to do my own version of it, until I remembered that openbox can't draw rounded borders xD)

Report

duet

3 years ago

Hola, Which version of Ubuntu you've tested?

I'm current using Ubuntu 14.04 LTS.

Best regards,

Report

C

nhermosilla14

3 years ago

I don't remember it, because I did it at January 2014. But I believe it was 13.10, just because I don't have many Ubuntu ISOS at my pc, so I think it would have been easier to find that version then. If you are using any later version, everything should work fine. Just be sure to avoid Lubuntu, and use only Ubuntu with the LXDE package installed.
Regards!

Report

gonzges

3 years ago

Hi,
I was trying to install win ate in wheezy 7.5 but when I type the command by terminal i got this error:

1)Español
2)English

1/2?
2
./install.sh: 66: [: 2_: unexpected operator
./install.sh: 122: ./install.sh: Bad substitution

or this:
Su distro parece ser Debian. ¿Es correcto?(S/n)
Las carpetas de sistema no coinciden, o la distribución no está soportada. Para forzar la instalación, use "--force". Saliendo...

All the dependency are installed, so I don't know, but I really need to get work, can you help me please?

Thanks
gonzges

Report

C

nhermosilla14

3 years ago

Well, first of all you are using a non-supported distro. I tested it in Wheezy and everything went wrong. You should do the same as in the RasPi case.
Second, I've just tried the language selection, and for me it works, so I guess the problem is something you are writing wrong (I don't have a clue on what could it be, cos'...well, it's just a "2" .-.). I'm pretty sure that you can install everything by yourself, just sent me an email and I'll will answer it with the needed steps (do that by going to github, the link is at the beginning of this page).

Report

LGe400

3 years ago

i'm using Ubuntu 12.04 LTS
how to instal this ??

Report

C

nhermosilla14

3 years ago

Install all the dependencies and run the script, everything should work fine (I've not tested it in that specific version thought, but I guess all the dependencies should be satisfied). Just be sure to install "lxde" package, not "lubuntu-desktop" one.

Report

bluedxca93

3 years ago

hi,
can you tell me which license has "dm" theme?.
im also interested in install script.

btw. your theme is really horifying for an windows theme. look at my. w7-n theme.it is still far from an 100% clone but ... . ambiance 69 makes better win themes than you are doing.
please create linux looking themes its easier to do and it isn't good to start directly which such an difficult task.

you know that people who hate win would rate you down. people that expect win themes too.
just for an test: modify theme à bit and post it umder another name. people wouldnt vote down it so quickly. my first win themes were so bad that i had to delete them from gnome-look. they were more buggy than your theme.

your theme might resemble. win7 à litlle bit, but it is absolutely not looking like windows. ill vote it up, but..

Report

C

nhermosilla14

3 years ago

Well, you obviously didn't read anything at github about this. Do that and comment again, because almost everything you said or asked is already replied there.
Regards!

Report

bluedxca93

3 years ago

hi,
you seem to follow the same goal as knoppix, startos or zorinos8, but for lowram systems.
you want an system that is to use that easy as windows, to help people migrating from windows.

anyway, you could also use. spacefm lxpanel and pekwm( is an fast , highly themable and not wellknown window manager).
your themes are under gpl. thx.

regards
bluerxca93

btw: i didn t search theme name on google , so i couldnt read github description.

Report

C

nhermosilla14

3 years ago

The github repo were always in this page, at the beginning.
Anyway, I'll check pekwm to see what can I do with it; I'm currently looking for a replace for openbox with support for not only 90 degrees corners at windows.
Regards

Report

Netwebtech

3 years ago

Hi There
Would i be able to use your pack in some way on a raspberry pi running rasbian (Raspberry pi version of debian)with LXDE
Thanks for the great work

Report

C

nhermosilla14

3 years ago

Hi! The truth is I don't really know what version of Debian is Raspbian actually. If it is 8 or later, evertything should work just fine. If it isn't...well, all the themes will work fine, but you will have to install and apply them manually. I can guide you to achieve exactly the same results, but you're going to need much more time than if it worked out-of-the-box. It probably works best with Arch on a RasPi, but within a couple of hours you should be able to set it up in Debian or in any other distro you like. Send me an email (you can do that by visiting my git account) for further information. Thanks for your comment, and...please rate positive! :D

Report

jycg

3 years ago

Hi,
Thank-you for the additional information. What I eventually ended up doing was installing the package in an isolated test environment. I made a number of modifications to the install script provided with the package so that it would not negatively impact any of the standard system files or directory locations and then I experimented with account environment files until I got a desktop look that somewhat resembled a Win7 environment. What I really wanted most of all from the Windows desktop environment was the vertical and horizontal scroll-bar functionality. Although I have not been able to duplicate this using the X11 clients I have been able to get something close enough that I can use when scrolling in certain client applications. I`ve decided to wait a while to see if a working Win7 or Win8 theme (or decent lookalike) that can simply be selected using the Openbox Configuration Manager that comes with the standard Lubuntu desktop manager environment. Version 14.04 is very new as a release for Lubuntu so I expect this type of theme will eventually become available. I may also decide to go with the cairo dock environment (see glx-dock.org) after I experiment with it for a while since it`s a fairly slick looking desktop environment.

Report

jycg

3 years ago

Hi,
You mention that you intend to provide a version that will work on the Lubuntu platform. I just recently installed the Lubuntu 14.04 LTS release(with the provided LXDE desktop) on my laptop. Will the version you expect to provide for Lubuntu work with this release/version? I would really like to get a Win7 like desktop theme for this release of Lubuntu.

Report

C

nhermosilla14

3 years ago

Yeah, I've been very busy, but if you want to install this, you still can without my own script. The pack itself contains everything you need to have the proper themes working, so the only thing you have todo is to copy the openbox theme and the gtk theme to ~/.themes, and the cursor and icons to ~/.icons
Then, the next step can be done by using the standard GUI tools that Lubuntu provides.
The panel is a bit trickier, but I suppose you can overwrite the config file placed on ~/.config/lxpanel/panels/panel to be the same that I put on the package (it is on the conf folder, inside lxpanel, there's one for each theme). Every config file is in that folder. The backgrounds are in the expected folder, and...I truly can't remember anything else that could work in Lubuntu. If you have any doubt, please send me an email :P

Report

3 years ago

0.1 First version, lots of errors
0.2 Almost everything work, apparently something happened with the cursor
0.2.1 Found the mistaken location for the cursor
0.2.2 A few improvements in compatibility
0.3 Lots of improvements! I have re-written the install script, and now it fails so much less than before
0.3.1 Removed msstyles, due to Copyright issues
0.4 Completely rewritten themes. Now it looks a lot much like Win8
0.4.1 Official Win8 wallpapers added
0.5 Merged version 0.3.1 into W8 script, added new features and uninstall script now it\'s been auto made each time you install
0.5.1 Fixed wallpaper recover when using uninstaller
0.5.2 Fixed ob-theme issues (if nothing happens, this could be the first RC)
0.6 RC-1 Whole new installer, now much smarter than ever! Auto-detects non-compatible distros, and writes a perfect uninstaller (everything is restored with a single click). Added GTK3 support, Win8 cursor and GTK2 theme.
1.0 Minor details improved. Added experimental support for SLiM
1.1 Added complete support for SLiM.
1.2 Added ability to customize SLiM background.
1.2.3 Now using sudo to gain root access
1.2.4 Login background minor bug fixed.
1.3 Minor bugs fixed. Added support for Arch Linux. Now you can turn off aero-like effects.
1.3.5 Minor bug that were making it impossible to install it without compton fixed. Translation to french added. Thanks to Franí§ois Foyer :D

product-maker R3IN Sep 09 2016

product-maker bohoomil Jun 07 2014

product-maker Wapush Jun 06 2014

product-maker Nina07 Jun 05 2014

product-maker gonzges May 25 2014

product-maker feedos May 21 2014

product-maker bluedxca93 May 20 2014

product-maker ZMA May 20 2014

product-maker dewman12 May 19 2014

product-maker Netwebtech May 19 2014

product-maker jycg May 05 2014

product-maker Ambiance-69 Apr 26 2014

product-maker droper03127 Feb 21 2014

product-maker droper03126 Feb 21 2014

product-maker droper03125 Feb 21 2014

product-maker droper03124 Feb 21 2014

product-maker droper03123 Feb 21 2014

product-maker droper03122 Feb 21 2014

product-maker droper03121 Feb 21 2014

product-maker droper02127 Feb 21 2014

product-maker droper02126 Feb 21 2014

product-maker droper02125 Feb 21 2014

product-maker droper02124 Feb 21 2014

product-maker droper02123 Feb 21 2014

product-maker droper02122 Feb 21 2014

product-maker droper02121 Feb 21 2014

product-maker Moatib Jan 30 2014

product-maker 6 6

File (click to download) Version Description Filetype Packagetype License Downloads Date Filesize OCS-Install DL
Details
version
updated Jul 14 2017
added Jan 28 2014
downloads today
0
page views today 17